Hubsan H501S Problem With Follow Me and Headless Mode Features

Discussion in 'Specific Models of Quadcopters and Drones' started by Mike R, Feb 20, 2017.

  1. Mike R

    Mike R New Member

    Hello All,

    I am brand new to quad copters and am having fun with this new hobby. Just bought my first, a Hubsan Quads H501S advanced version. Went to the Hubsan Quads web site, downloaded and installed the following (latest) firmware versions: Flight Controller (FC): V1.6.25, Receiver (RX): V1.2.16, and the H906A advanced transmitter V1.1.6. I then took out the H501S to explore the features and to get some practice flying. The quad copter and transmitter were both able to find gps satellites (as I remember about 12 on each). The quad copter seemed to fly well. The gps hold feature seems to work. The return to home feature also seems to work well. I then tried the follow me feature (flipped on the follow me switch while in gps hold mode). The transmitter says it is in follow me mode but the quad copter just stays in the same spot and hovers. It does not turn and face the camera towards the transmitter or make any attempt to move at all when the transmitter moves (it behaves like it has no idea where the transmitter is). The other issue I have is with headless mode. Seems like I can only get headless mode to work if I stand directly behind the quad copter and flip on the headless mode switch (although the transmitter always says it is in headless mode when I flip the headless mode switch). Again, it seems like the quad copter has no idea where the transmitter is. It is like it just using its own orientation for headless mode instead of where it is in relation to the transmitter. Has anyone ever experienced this? Am I doing something wrong? Is this a problem with the quad copter hardware? Is this a firmware issue (I strongly suspect that this is a firmware issue)? Does anyone know where to get earlier versions of the firmware (where they are certain that these two features work) so I can do more testing? Hubsan Quads does not seem to provide and type of firmware release archive or make any of the earlier firmware versions available.

    Any help or advice would be greatly appreciated.
  2. Mordi

    Mordi New Member

    I have the same problems..
    Did you figure it out?
  3. Mike R

    Mike R New Member

    The broken follow me feature is a firmware issue (confirmed by Anne Lu at Hubsan Quads). I got the follow me feature to
    work with the following firmware versions: (FC) V1.1.22, (RX) V1.2.12, and the H906A advanced transmitter V1.1.6
    I also tried substituting (FC) V1.1.23 and (FC) V1.1.24 with the above combination, but they all seem to break the
    follow me feature. I was not able to find any earlier firmware versions to download and test. Hubsan Quads does not do a
    good job of providing firmware archives or letting anyone know what versions FC, RX, and transmitter work together.
    As of today, Hubsan Quads has no firmware downloads available on their website (they seem to put them on the site, remove
    them from the site, and move them around on the site). I am not sure how you are actually supposed to get any firmware
    except for emailing Anne Lu and asking her for a link.

    As far a headless mode goes, every version of firmware I have tested works the same. If you turn on headless mode,
    it works from the perspective of the direction the quad copter is facing at the time you turn headless mode on. This
    is OK if the quad copter is facing directly away from you at the time you turn headless mode on. I was thinking I could
    use headless mode as a safety feature if I am flying and get confused to which way the quad copter is facing. I could
    then make the quad come back to me by puling back on the right stick. In reality if you don't know which way the quad
    is facing and you turn on headless mode, you will have no idea which way the sticks are going to mode the quad. I am
    new to quads and can't say for sure, but can't believe this feature is working is correctly (especially since the quad
    knows where the controller is). For now, if I get into trouble, I activate the return to home feature.

    For the most part, I really like this quad. I bought it so I could learn to fly before buying a more expensive quad.
    I think it provides good features for the money and I am having fun with it. I have crashed a few times and the quad
    has survived with no damage (except for props). I am a big fan, even with the firmware issues.
  4. Freeflyer

    Freeflyer New Member

    Not sure I understand what you want it to do but in headless mode, no matter what direction the quad faces when you turn headless mode on, it responds only to what the stick does. You push forward, it goes out. You pull back, it comes back. If it is 90 degrees to you( you are looking at the side of it), it will go straight out that way and come back that way. You can hold the left stick full right (making it spin) and it should still just respond to what the right stick is doing. Don't know if this helps.
  5. Mike R

    Mike R New Member

    Last edited: Mar 19, 2017
  6. Mike R

    Mike R New Member

  7. Freeflyer

    Freeflyer New Member

    Yep. You have the right idea and no, your quad is not behaving correctly. I've not heard of this before but I haven't seen everything either. Most people have issue with the "follow me mode" but Hubsan Quads has acknowledged that they have a problem there. Make sure you are doing everything according to your user manual. Wish I could be more help. Sorry.
  8. Dodgersylm

    Dodgersylm New Member

    I just received my new 501ss. from what i am hearing on youtube i believe i have the updated version. I only say this because of the packaging. Mine came with the old style remote. ( Larger Screen ) and a rechargeable battery for the controller. Regardless of how many GPS satellites i have for the drone and the controller, I am unable to fly in Headless mode. Any advice ? controller firmware is 4.2.34
  9. Owen Phillips

    Owen Phillips New Member

    Just purchased a Hubsan Quads H501S with standard controller. How can you tell what version of firmware is on the drone and transmitter? I too could not get it to work in headless when I tried to test.
  10. Owen Phillips

    Owen Phillips New Member

    I have since got it to work in headless mode!

Share This Page