Help setting up my Eachine Racer 250

Discussion in 'Specific Models of Quadcopters and Drones' started by Talha K, Jul 10, 2017.

  1. Talha K

    Talha K New Member

    Hey all, I've been wanting to get into FPV racing for a while now and I finally got my hands on an Eachine Racer 250. But, I'm having trouble configuring the quadcopter.

    I was able to bind my transmitter (FlySky i6X) to my receiver (FS-iA6B) via i-Bus. I also flashed my NAZE32 Flight Controller firmware in bootloader mode on CleanFlight. The quadcopter is detected on my computer and the gyro map shows the direction and movement of the quad perfectly. I have selected iBus Signal type in the configuration tab on CleanFlight as well. However, when I go to the receiver tab, whenever I move any of the sticks on the transmitter (while battery is plugged in), none of the bars move, not even any jitter - they are consistently stuck at 1500 and 885 for throttle.

    When I also plug in the battery to the quad, it makes a weird bootup beep.. i.e. it goes like "beepbeepbeeep" instead of the normal "beep...(pause)...beep..(pause)...beepbeepbeep".

    I'm sure I have all the connections in properly and flashed the NAZE32 FC correctly, but I am getting frustrated why it's still not working.

    Hence I have resorted myself to come here for help. Thanks for your time in reading and hope you can provide some assistance!
  2. RGJameson

    RGJameson Active Member

    Make sure in CleanFlight you have chosen AETR1234, which is the FS mapping.
  3. Talha K

    Talha K New Member

    I do have AETR1234 selected, tried others too.. still wouldn't work..
  4. RGJameson

    RGJameson Active Member

    Why bother trying the wrong channel maps?
    Those are famous last words. If you truly believe that then replace the Naze32 (F1 generation). I word suggest a more modern F3 FC.

Share This Page